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EXCEL TOOLS BUILD ANY TYPE OF SALARY SCHEDULE

 Salary Schedules come in many shapes and sizes

 Salary Schedules used to communicate wage agreements with employees usually by employee groups.

 Salary Schedules combined with fulltime equivalency listing can be used to budget and project total wages for 
given school year

 Typically a LEA has multiple Salary Schedules and various Schedule Types.

 Excel has powerful tools to build any style salary schedule quickly 

 Excel tools for building a basic salary schedule provide quick results.
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DIFFERENT TYPES OF SALARY SCHEDULES
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Contracted Certified Staff Salary 
Schedule

Traditional Step and Grade Salary 
Schedule used with Contracted Staff
Structure:
Years of Service
Step
Grade 

Highlighted rows are salary freeze 
years
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DIFFERENT TYPES OF SALARY SCHEDULES
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Administrative Staff Salary 
Schedule

Educational level ranking

Structure:
Level and Grade (Rank)
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Central Office Staff Salary 
Schedule

Position level ranking

Structure:
Position/Rank – salary schedule #
Years of Experience

Different types of salary schedules
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Health Contractual Staff 
Salary Schedule

Position level ranking and 
number of days in contract

Structure:
Position/Rank 
Schedule # 
Contract Days
Daily rate and Annual salary 
calculations
Years of Experience

Different types of salary schedules
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BUILDING SALARY SCHEDULES WITH EXCEL 

Factors to consider:
 Contractual and Non contractual staff contracts or agreements (unions and not!)

 Number of employees;  FTE staffing list

 Salary Ranges and Performance

 Budgets decisions

Schedule Formats and Structures
 Multiple schedules relating to employee groups and positions 

 Various types different formats and structures

Excel tools can quickly transform information into any type of format or 
structured Salary Schedule
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To Build a Salary Schedule with Excel:

• Identify the type of schedule or schedules you are developing

• Is the schedule a new or a existing schedule

• Obtain copy of all current salary schedule

• Will the salary schedule include other benefits? If so get the benefit information

• For costing assumptions for budget or projections need Fulltime equivalency 
staffing schedule

Building a Business Salary Schedule with Excel 

EXCEL TOOLS FOR BUILDING SALARY SCHEDULES

Excel has many powerful tools to help build any style salary schedule

We will review the following features in examples to build a basic salary schedule

 Formulas for quickly calculating salary, incrementing salary ranges, or calculating increases

 Copy and Paste Special quickly prepopulate cells with data using these options

 AutoFill Options quickly prepopulate cells with data or a formula

 Goal Seek to assist with projecting salary increases fixed amounts and percentages

 Linked worksheets – powerful salary schedule budget calculations 

 Show Formulas Feature – handy tool to audit schedule formulas

 Transpose
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Steps to Create a Basic Salary schedule in Excel

1. Open a new Excel workbook and save it with a meaningful file name..

2. Enter the column headings labels "Rank," "Step" and "Wage" in the top row. 
Enter all possible Ranks and positions from lowest to highest rank. For example, use labels such 
as “Office Assistant,” “Secretary” and “Administrative Assistant" for a office.

Use Excel powerful Auto Fill Options to 
quickly populate data

Click the icon in corner of cell, hold and 
drag

Auto Fill launches and auto fills data in cells

To Select specific Auto Fill Options click 
drop down arrow
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Steps to Create a Basic Salary schedule in Excel

Format Row and Column labels with the Format Cells options

To Format Select or highlight data to format 
Use Format options located on the Home Tab to format cells
Click icon displayed in the corner of each Ribbon group to launch Format Cells dialog box

Or with cells selected right click and select Format Cells
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Steps to Create a Basic Salary schedule in Excel

3. Enter all possible Steps for each position. 

Use Excel Copy and Paste Or Auto Fill features to quickly populate data series

Using the example, if an Office Assistant has three levels before becoming an Secretary, input “1,” 
“2" and “3" to the right of the rank in the "Step" column.

Use Auto Fill Options > Fill Series to populate Step data 
cells

Enter 1 in first cell in Step column, than 2 in next cell, than 
click and drag icon in corner of cell,  Auto Fill activates drag 
to last cell, Select Fill Series
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Steps to Create a Basic Salary schedule in Excel

4. Enter the salary for each step 
in the "Wage" column. 
In this example enter 25,000 in 
first cell in Wage column

In second row enter the 
formula such =25,000*1.05 
to assign 5 percentage wage 
increase for each step.  

Use Excel AutoFill to copy 
formula to all cells, click and 
drag cell corner icon, select 
Copy Cells to copy Formula 

Format the data type in the 
"Wage" column as Currency, 
highlight data, right click and 
select Format cells, select 
options in dialog box
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Steps to Create a Basic Salary schedule in Excel Complete!

Basic Salary Schedule Example, Structure: Rank - Step - Wage

To review formulas used in Wages column Select Formulas Tab > Show Formulas 
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Create Basic Salary Schedule projection or budget 

Using existing Salary Schedule Add column for current staffing information also 
referred to as full time equalivant staff list.

Staff list is a point in time view of staff employed, select date that best represents staff 
employed by LEA

Enter the point in time staff 
employed data for each 
Rank/position

Add Column for Budget

Enter formula to calculate 
actual costs based on salary 
schedule and staff FTE
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Create Basic Salary Schedule projection or budget 

Use Auto Fill to copy formula down in Budget Column
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Create a Basic Salary Schedule budget  

Use AutoSum to add a total to 
the Budget column

• Click in bottom cell in Budget 
column

• Select Formulas Tab > 
AutoSum

• Click Enter

• The Salary Schedule contains 
budgeted cost information 
based on a point in time staff list
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Create a Basic Salary Schedule budget estimate

Use Excel Goal Seek to determine a % of salary increase for targeted amount of increase

Add Column for Budget estimate, and two fields for % of increase and amount of increase
Enter % information into cell

Enter Formula in first cell in Budget estimate column multiplying prior year cost by fixed % of 
increase
Edit formula adding absolute cell reference to % of increase cell  ($- absolute reference of rows and 
columns in formula) ($G$2), hit enter when formula edit complete
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Create a Basic Salary Schedule budget estimate  

Use Auto Fill to populate Budget estimate column cells with Formula

Use Show Formulas feature 
to confirm Formula is 
referencing % of increase cell 
with absolute cell reference

In Example is cell $G$2

Toggle Show Formulas off by 
clicking option on ribbon
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Add a Total to Salary Schedule 
Budget estimate column

Click in last cell in the column

Select AutoSum on Formula 
Tab

Create a Basic Salary Schedule budget estimate  
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Add a Formula to calculate the 
amount of increase referencing 
the two Total columns

Use Auto Fill copy formula to 
cells in estimate column

Add a Total to the Estimate 
column using AutoSum

Create a Basic Salary Schedule budget estimate  
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Salary Schedule with Staff FTE, Current Budgeted Costs, and Estimated Budget 
Costs based on % of salary increase

Create a Basic Salary Schedule budget estimate  
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EXCEL GOAL SEEK AND SALARY SCHEDULES

Use Excel Goal Seek to find quick answers to Salary Schedule Estimates or Changes 

If you know the results you want from one variable in a formula Goal Seek with determine the 
input value need to get the result.

Goal Seek is a Excel tool that allows a user to run scenarios

Goal Seek is located on the Data Tab
What-If-Analysis Group
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Use Excel Goal Seek feature with Salary Schedule to determine % of salary 
increase for a fixed amount of increase

Click in cell amount of increase
Select Data Tab > What-If Analysis > Goal Seek

Excel Goal Seek and Salary Schedule projections
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Click in cell amount of increase
Select Data Tab > What-If Analysis > Goal Seek

Set Cell: is the cell with the flat amount of increase formula 
To value: enter the flat amount of increase desired
By changing cell: is the cell with the % of increase
Click OK to run

Excel Goal Seek and Salary Schedule projections
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Excel Goal Seek returns the value for % of increase needed to hold increase cost to 30,000  
and updates all the Wages in the Estimate column

Excel Goal Seek and Salary Schedule projections
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Goal Seek can be used to calculate Salary Schedule estimate based on % of Salary 
increase and amount of increase

Excel Goal Seek and Salary Schedule projections
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CREATE A SALARY SCHEDULE ESTIMATE USING EXCEL GOAL 
SEEK – EXAMPLE WITH LINKED WORKSHEETS

To create a salary schedule estimate start with existing salary schedule and a Fulltime equivalent 
staff listing. Link these two sheets together to calculate salary schedule actuals cost sheet, than 
setup a new sheet for new year projection where a set flat amount of increase and or % increase  
set in specific cell than run scenarios with Excel Goal Seek
In Excel workbook add worksheets for 

Current salary schedule
Current FTE staffing matrix
Current FTE & Salary schedule with actual costs  

Next setup a final sheet for new or next year salary schedule linking current salary schedule to 
current FTE staffing matrix with a absolute cell reference for % increase to run scenarios

EXCEL SALARY SCHEDULE WITH BENEFIT INFORMATION
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• Excel is a powerful intuitive tool with the flexibility to quickly transform any existing schedule into different 
types of schedules with additional information including benefits.

• If you need to include benefit information structure the schedule with columns for each benefit type, write 
formulas on first row of data and quickly fill additional cells with Auto Fill feature using previous examples.

EXCEL IS THE PERFECT TOOL FOR BUILDING AND MANAGING 
SALARY SCHEDULES
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Building Salary Schedules may be intimidating timely task thanks to Excel the task may 
actually be fun and rewarding!

Excel has unlimited number of features and functions that can assist with Salary 
Schedules

Building Basic Salary Schedule is quite easy and quick with Excel powerful features
Copy and Paste Special
Auto Fill Options custom to data types
Formulas and absolute cell references
Show Formulas 
Goal Seek powerful What If Analysis
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EXCEL: BUILD A SALARY SCHEDULE

References:
 Hillsborough County Public Schools School Employee_Salary_Schedules.pdf

 Etowah County AL School system salary schedules 

 How to Build Pay Grades

 How to Make a Salary Scale Spreadsheet

 How to make salary sheet using Microsoft Excel

 Salary Schedules and Calculator Page Multnomah Education Service District Oregon

Tracy S. Leed Accounts Payable Supervisor/System Adminstrator

Chester County IU 24 Downingtown, PA 19335

TracyL@cciu.org
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